Computer Requirements

Supported Browsers

Blackboard and DLT support the latest versions of the following browsers:

  • Google Chrome
  • Mozilla Firefox
  • Apple Safari
  • Microsoft Edge

We are working to improve support for mobile browsers, as well, but full feature parity cannot be guaranteed.

Blackboard's vendor team tests accessibility against the latest two versions of the JAWS screen reader.

Supported Devices

Blackboard's vendor team performs usability testing against several devices and operating systems, including:

Type Tested Against
OS Windows 7, Windows 8, Windows 10, Mac OS 10.8, Mac OS 10.9, Mac OS 10.10, iOS, Android, Windows Mobile, Chrome OS
iOS Devices iPod Touch , iPhone 4S, iPhone 5S, iPhone5c, iPhone 6, iPad 2, iPad 3, iPad Mini 3, iPad Air 2
Android Devices Galaxy S4, Galaxy S5, HTC G1, LG C800 myTouch, HTC One, Galaxy Note 2014, HTC One M8
Windows Mobile Devices Venue 8 Pro, Lumia 520, Lumia 930
Chrome OS Devices Chromebook

Browser Plugins

Blackboard itself does not require any browser plugins in order to function. In particular, client-side Java is not required.

However, some courses use proprietary content types or other integrations that may require additional software or plugins in order to function correctly. Please check with your instructor if you are unsure about software requirements for your course materials.